Skip to content

Fixes the install error in Python 2.7 and CircleCI error with Python 3.4.8 - #141

Merged
pombredanne merged 2 commits into
spdx:masterfrom
ShubhamKJha:fix_tests
Jun 17, 2020
Merged

pombredanne merged 2 commits into
spdx:masterfrom
ShubhamKJha:fix_tests

Conversation

@ShubhamKJha

Copy link
Copy Markdown
Contributor

Signed-off-by: Shubham Kumar Jha skjha832@gmail.com

Fixes #140
Build failures were occurring in Python2 due to rdflib allowing any version of pyparsing (it's dependency) to be installed. It eventually installs the latest version which doesn't work with Python 2.7.

Fix:

  • Updated setup.py file to install pyparsing <= 1.5.7 when installed with Python 2.7
  • Since, rdflib allows any version of pyparsing to be installed, the latest version is not installed.

Signed-off-by: Shubham Kumar Jha <skjha832@gmail.com>
@ShubhamKJha

ShubhamKJha commented Jun 17, 2020 •

Copy link
Copy Markdown
Contributor Author

@pombredanne I've fixed the issues with Python 2.7

But the build is also failing for Python 3.4.8 (apparently as the error logs say, brew is not able to install it), I've made some changes but I can't get the build started for Circle CI to confirm changes.
@pombredanne can you start the builds.

Signed-off-by: Shubham Kumar Jha <skjha832@gmail.com>
@ShubhamKJha ShubhamKJha changed the title Fixed the version of pyparsing for Python 2.7 Fixes the install error in Python 2.7 and CircleCI error with Python 3.4.8 Jun 17, 2020
@ShubhamKJha

Copy link
Copy Markdown
Contributor Author

The CircleCI error happening with Python 3.4.8 is due to the updated version of pyenv (used to install different Python versions) which has a dependency on openssl-1.1. The support for openssl-1.1 is provided by Pyhon 2.7.13 and Python 3.5 +.

Fix: Pinning the version of pyenv (1.2.13) which requires openssl-1.0 fixed the problem.

ping @goneall @rtgdk @pombredanne Please, check this PR and merge.

@pombredanne pombredanne left a comment

Copy link
Copy Markdown
Member

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

LGTM! thank you

@pombredanne
pombredanne merged commit ee5a7d7 into spdx:master Jun 17, 2020
@pombredanne

Copy link
Copy Markdown
Member

note that we do not want to support Python 3.4, actually going forward any version under 3.6 should be dropped.

@ShubhamKJha

Copy link
Copy Markdown
Contributor Author

Dropping support for older Python version would be great. I just felt that we may need to use this in spdx-online-tools, which currently uses Python 2.7, so it must be installable with that.

@ShubhamKJha
ShubhamKJha deleted the fix_tests branch June 17, 2020 12:07
@pombredanne

Copy link
Copy Markdown
Member

Dropping support for older Python version would be great. I just felt that we may need to use this in spdx-online-tools, which currently uses Python 2.7, so it must be installable with that.

2.7 is obsolete, so spdx-online-tools would have to stick using older versions IMHO.

@goneall

goneall commented Jun 17, 2020

Copy link
Copy Markdown
Member

There's work in progress to upgrade the SPDX online tools to Python3: spdx/spdx-online-tools#178

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Labels

None yet

Projects

None yet

Development

Successfully merging this pull request may close these issues.

Build failures occurring in Python 2.7

3 participants