Repository navigation
PSA: it's now possible to start Jenkins CI by adding request-ci label to PRs #34594
Description
Activity
- addedmetaIssues and PRs related to the general management of the project.Issues and PRs related to the general management of the project.
on Aug 1, 2020 I tried in #34629, looks like failed.
Not sure it's related to graphql query
https://github.com/nodejs/node/actions/runs/195904308.github#L1 Unexpected input(s) 'owner', 'repo', valid inputs are ['query']
BTW it looks like the job's name is wrong (commitQueue)
@gengjiawen that warning is ignorable, unfortunately I don't know how to supress it. Here's where the action failed: https://github.com/nodejs/node/runs/948079537?check_suite_focus=true. No relevant error messages. I'll increase verbosity of the logs to see if we get any clues.
@targos good catch, I'll fix the job name.
- added 2 commits that reference this issue
on Aug 5, 2020 @gengjiawen I tried again on the same PR and it worked 🤔. Let me know if you try again on another PR and it doesn't start the CI.
Reacted by Jiawen Geng- added 3 commits that reference this issue
on Aug 6, 2020 In #34796, the second time I added
request-ci, CI was started correctly but the bot didn't comment on the PR with the jenkins link.That's a Jenkins wide issue unfortunately (not related to the Action as far as we know): nodejs/build#2413
@ronag yeah, there was a short discussion in #34089 about it but I guess we decided that it will be implicitly assumed when adding a label (though there is a short lag/time where someone can push changes before the CI starts which may be an issue). I guess we could put that in label description but I don't think it's noticeable there.
Reacted by Robert Nagy- added 2 commits that reference this issue
on Sep 22, 2020 Looks this one not triggered #35324

Jenkins is shutting down, probably related
I am thinking if we can run extra CI job: https://ci.nodejs.org/job/node-test-commit-v8-linux/ if PR labeled with
V8 Engine. cc @nodejs/v8Shouldn't be hard from an implementation perspective, we just need to align if that's the behavior we want
SGTM.
Closing since this was a PSA and not a tracking issue

As title says, it's now possible to start Jenkins CI by adding
request-cilabel to PRs. CI will start a few minutes after the label is added. No extra involvement is needed from collaborators to start the CI after the label is added. Collaborators can add the label while creating new PRs, which will result in the CI starting soon after the PR is opened.Since this was added recently, let's treat it as experimental for now (at least until it has been more extensively tested in this repository), but it should work on most cases. If anyone finds a bug with it, please leave a comment here. Once we have confidence this feature is stable we should update the collaborators guide to instruct new collaborators to use it as well.