You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
PHP 5.4 is not longer supported by the PHP community, which causes that bugs (also security ones) might not get fixed 😱 Nextcloud 9 does still support this version (for whatever reason). Dropping it instantly makes no sense, because it is currently supported in Nextcloud 9.
We have two options.
Warn users in "Security & setup warnings" section about the outdated PHP version
Requirements such as versions should always be driven by: "How widely is something available?"
When it comes to PHP 5.4, it is luckily the case that all decent distributions ship 5.5, 5.6 or even 7.0. Below list contains the current supported versions by the current distribution supported OS versions:
Ubuntu 12.04: 5.3 (This means you anyways need PHP from third-party sources)
Ubuntu 14.04: 5.5
Ubuntu 16.04: 7.0
Debian 8: 5.6
RHEL 6: 5.3 (you can update via SCL up to 5.6)
RHEL 7: 5.4 (you can update via SCL up to 5.6)
This means that the installation experience for RHEL 7 and CentOS 7 users will be a little bit harder since you manually need to update to PHP 5.6 via SCL. It would however be possible to detect these cases and display the required commands in the dependencies screen on setup.
Considering that SabreDAV will drop support for 5.4 (http://sabre.io/dav/install/) we indeed may have to discuss this more. Personally, I don't see so many advantages on 5.5 vs. 5.4 from a developer point of view though. It's not like there would be a lot of awesome synax sugar as in PHP 7 :-)
Warn users in "Security & setup warnings" section about the outdated PHP version
This already happens. Tested with default PHP from Centos 7:
selectie_426
Note that these PHP versions are EOL for the PHP developers but the distributions still support them.
the same is in debian 7. The php 5.4 is supported bei the debian long term support.
I think this warning is too halfhearted. I'd change it and clearly state that php 5.4 and 5.5 have reached end of life and that it's therefore a major risk to still use these.
On the subject of dropping support: I would drop it as soon as Owncloud drops it - to keep full compatibility. It basically seems decided that Owncloud will stop supporting PHP 5.4 as of version 9.2 so I would drop it in the Nextcloud equivalent too: owncloud/core#25408
And yes, there are still some distros like Debian Wheezy (with EOL on 31 May 2018) for example, but Nextcloud 10 would still be there for these guys. Someone who runs really outdated (versions of) distros, should be perfectly fine with not running the absolutely latest Nextcloud release.
Activity
MorrisJobke commentedon Jun 14, 2016
cc @karlitschek @LukasReschke
LukasReschke commentedon Jun 15, 2016
Requirements such as versions should always be driven by: "How widely is something available?"
When it comes to PHP 5.4, it is luckily the case that all decent distributions ship 5.5, 5.6 or even 7.0. Below list contains the current supported versions by the current distribution supported OS versions:
This means that the installation experience for RHEL 7 and CentOS 7 users will be a little bit harder since you manually need to update to PHP 5.6 via SCL. It would however be possible to detect these cases and display the required commands in the dependencies screen on setup.
Considering that SabreDAV will drop support for 5.4 (http://sabre.io/dav/install/) we indeed may have to discuss this more. Personally, I don't see so many advantages on 5.5 vs. 5.4 from a developer point of view though. It's not like there would be a lot of awesome synax sugar as in PHP 7 :-)
karlitschek commentedon Jun 15, 2016
let's discuss for the next major release. at the moment it has to stay because of old enterpriser distributions.
LEDfan commentedon Jun 15, 2016
This already happens. Tested with default PHP from Centos 7:

Note that these PHP versions are EOL for the PHP developers but the distributions still support them.
happyreacer commentedon Jun 21, 2016
the same is in debian 7. The php 5.4 is supported bei the debian long term support.
PascalReintjens commentedon Jul 24, 2016
I think this warning is too halfhearted. I'd change it and clearly state that php 5.4 and 5.5 have reached end of life and that it's therefore a major risk to still use these.
On the subject of dropping support: I would drop it as soon as Owncloud drops it - to keep full compatibility. It basically seems decided that Owncloud will stop supporting PHP 5.4 as of version 9.2 so I would drop it in the Nextcloud equivalent too: owncloud/core#25408
Additionally, it may be possible that Owncloud 9.2 will drop PHP 5.5 too (see https://central.owncloud.org/t/kill-php-5-5-as-well-for-9-2/866) and I'd follow this decision likewise.
And yes, there are still some distros like Debian Wheezy (with EOL on 31 May 2018) for example, but Nextcloud 10 would still be there for these guys. Someone who runs really outdated (versions of) distros, should be perfectly fine with not running the absolutely latest Nextcloud release.
MorrisJobke commentedon Jul 25, 2016
That is already the plan. They asked us to comment on this thread too. :)
MorrisJobke commentedon Aug 5, 2016
Move to Nextcloud 11. we will support PHP 5.4 with Nextcloud 10.
MariusBluem commentedon Aug 31, 2016
#1211 ... Closing here 😉