You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
Using both pip-tools or uv when trying to resolve dependencies where using uvicorn and httpx as a dev dependency will get confused and downgrade to httpcore 0.13.2 which is ancient.
I'm not 100% sure how this happens, but we had it on two separate codebases this morning. (one using uv and one using pip-tools).
It seems to stem from having a loose httpcore and h11 requirement on both cases (via e.g. uvicorn) where both resolvers prioritise h11 as it was pinned first and then the first version of httpcore that meets requirements is 0.13.2, it then also pulls in httpx to 0.25.1 as that's the higest version that doesn't require httpcore>1.
This results in a broken build as httpx needs the newer httpcore.
Looking at h11 it recently had a bunch of cleanup work done, in response to a reported cve, and has been api-stable for years now, so might be safe to relax the pin of it here.
Having similar issues here. The recent h11 CVE was addressed in h11 0.16.0. Bumping to this version causes the following dependency conflict from httpcore:
9.376 The user requested h11==0.16.0
9.376 httpcore 1.0.0 depends on h11<0.15 and >=0.13
Activity
rstmsn commentedon Apr 24, 2025
Having similar issues here. The recent h11 CVE was addressed in h11 0.16.0. Bumping to this version causes the following dependency conflict from httpcore:
lukehsiao commentedon Apr 24, 2025
This pinning is also preventing users from being able to update
h11to address the Critical-level CVE:GHSA-vqfr-h8mv-ghfj
due to httpcore's pin to <0.15
httpcore/pyproject.toml
Line 33 in ae46dfb
ljdelavega commentedon Apr 24, 2025
Hoping this small edit to the h11 dependency pin can help #1008
mlauchli commentedon Apr 24, 2025
pip-audit also fails when trying to install h11 for httpcore. We need an update to 0.16.0. Thanks!
Zaczero commentedon Apr 24, 2025
Sorry for the potentially odd question, but what's the reason behind
<0.15pin?lovelydinosaur commentedon Apr 24, 2025
It's there because we can't assume that a 0.x -> 0.y version update is necessarily going to be API compatible.
In practice
h11has been API stable for some time now, so we could be less restrictive.jgutilla commentedon Apr 24, 2025
I'm also having issues related to the Critical-level CVE. An update to bump h11 to 0.16.0 would be extremely usefull.
lovelydinosaur commentedon Apr 24, 2025
I will block users who pile in on issues.
httpcore 1.0.9is now released.@grigi I'm going to assume this is resolved. If you'd like it to be reopened can you clarify with a simple reproducible example?
Update httpcore to 1.0.9