Skip to content

If a VM resource is requested to transition in a state where it's already in, it returns success, instead it should return 'the resource is in the same state'  #2736

Description

@borisstoyanov
ISSUE TYPE
  • Bug Report
COMPONENT NAME
VM handler 

CLOUDSTACK VERSION
4.11
SUMMARY

If a VM is already running on HostA and the Admin requests a Start on HostB, it will return a success with the VM being started on HostA. Instead it should return an error to the administrator that the resource is already in running state.

STEPS TO REPRODUCE
  1. Start a VM on HostA
  2. With cloudmonkey, start the same VM on HostB
  3. Observe the result
EXPECTED RESULTS
Response should fail the job and say VM is already in the same state. 
ACTUAL RESULTS
Job succeeds with VM not being the requested host 

Activity

  1. DaanHoogland commented on Jul 11, 2018

    @DaanHoogland
    Contributor

    I would argue that the expected behaviour is a migration to host B but agree that the endstate does not qualify as a success. Do you request that this is implemented as failure result, @borisstoyanov ?

  2. borisstoyanov commented on Jul 12, 2018

    @borisstoyanov
    ContributorAuthor

    Yes @DaanHoogland, I do believe that it should return a failure if cloudstack is not able to execute the request with all required parameters.

  3. added a commit that references this issue on Jul 16, 2025
    78c34b5
  4. added this to the unplanned milestone on Sep 18, 2025
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Type

    No type

    Projects

    No projects

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions