Skip to content

GCP compute_loadbalancer_logging_enabled fails URL maps with backend buckets #12903

Description

@Vx-V

Issue search

  • I have searched the existing issues and this bug has not been reported yet

Which component is affected?

Prowler CLI/SDK

Cloud Provider (if applicable)

GCP

Steps to Reproduce

  1. Create an external Application Load Balancer whose URL map defaultService is a backend bucket
  2. Run prowler gcp --checks compute_loadbalancer_logging_enabled

Expected behavior

PASS. GCP enables logging for backend buckets automatically and it cannot be disabled: https://cloud.google.com/load-balancing/docs/https/https-logging-monitoring

For external Application Load Balancers with backend buckets, logging is automatically enabled and cannot be disabled.

Actual Result with Screenshots or Logs

FAIL: "LoadBalancer does not have logging enabled."
The URL map's backend bucket URI is looked up with backendServices.get(), so logConfig.enable defaults to False.

How did you install Prowler?

From pip package (pip install prowler)

Environment Resource

Github Workflow

OS used

Debian 13

Prowler version

5.43.0

Python version

3.13

Pip version

26.2.1

Context

No response

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions