You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
{{ message }}
Repository navigation
Commit 8fa321e
Browse filesBrowse the repository at this point in the historyBrowse files
fix(documentai-toolbox): Drop support for Python <= 3.9 (#16967)
This PR updates `google-cloud-documentai-toolbox` to establish Python
3.10 as the minimum supported version, dropping support for Python 3.9
and below.
### Changes
* **Configuration**: Updated `setup.py` and `noxfile.py` to require
Python 3.10+ and remove references to Python 3.9. Deleted
`constraints-3.9.txt`.
* **Documentation**: Updated `README.rst` and `CONTRIBUTING.rst` to
require Python 3.10+ and remove references to Python 3.9. Synced the
top-level `README.rst` to the `docs` folder.
* **Cleanup**: Removed obsolete warning suppressions in `pytest.ini`
related to Python 3.7 and 3.8. Updated the runtime version check in
`__init__.py` to warn on versions older than 3.10.
* **Dependency Fixes**: Resolved dependency conflicts on Python 3.10 by
bumping the minimum version of `google-cloud-storage` to `2.0.0` in
`setup.py` to avoid conflicts with `google-auth`. Added
`setuptools==79.0.0` to `constraints-3.10.txt` to resolve the
`ModuleNotFoundError: No module named 'pkg_resources'` and avoid its
subsequent deprecation warning.
Fixes internal issue: http://b/482126936 🦕
0 commit comments